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About forms

You can fill in forms using either Acrobat or the free Acrobat Reader. You can create static or interactive 
forms in Acrobat. Interactive forms streamline the process of filling in and collecting data.

You can use Acrobat to create forms using one of the following methods:

• Convert an existing electronic document (for example an Adobe PDF, Microsoft Word, or Excel document) 
to a PDF form.

• Scan a paper form to convert it to a PDF form.

After you convert an existing document to a PDF form, you can add fields to it to convert it to an interactive 
form. An interactive form can be filled out on a computer and submitted through an Internet or local network 
connection.

How to create a form from scratch

You can start with a blank PDF, add the required text and labels in the PDF, and then add form fields to 
complete the form.

1. In Acrobat, choose Tools > Prepare Form.
2. Choose Create New, and click Start. 

Save the PDF: In the upper-left corner of Acrobat window, click the Save icon, choose the location 
where you want to save the file, name the file, and then click Save.

If you don’t see the Create New option, update your Acrobat. To automatically update from Acrobat, choose 
Help > Check for updates, and then follow the instructions in the Updater window to complete the update 
process.

3. Click Add Text in the toolbar, and type wherever you want to add text or any other information in your 
form.

4. To add a logo or image in the form, choose the Add Image tool in the toolbar, select the image, click OK, 
and then place it at the desired location. Adjust the size or location of the image as appropriate.
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Below is an example form with labels created using the Add Text and the Add Image tools.

5. To change existing text or images, click Edit in the toolbar. All the text and image fields are enabled for 
editing.  

6. Add fields using the form field tools in the toolbar. Delete, resize, or arrange the fields as needed. To add 
a field:
(a) In the toolbar, click the tool corresponding to the field type, or right-click anywhere in the form and 

then choose the tool.
(b) Click at the desired location in the form to place the selected field.
(c) Set the field properties. The field properties vary based on the type of the form field.

While you’re adding fields, click Preview to see how they look. Click Edit to come back to the editing 
mode.

Considering the example of the Vacation Request Form, below screenshots show it in the editing mode 
and the preview mode.

7. Once you complete adding form fields, save the form.
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Create a form from an existing document

When you convert an existing document into a PDF form, Acrobat automatically adds interactive form fields 
to the form. You can then edit the form to add specialized form fields, such as a drop-down list, list box, or 
buttons.

Types of form fields you can add to a PDF
A. Certificate-based signature field B. Drop-down list box C. Text fields D. Automatic message bar E. Check boxes F. 
Radio buttons G. List box H. Buttons 

1. Choose Tools > Prepare Form.
2. Select one of the following options:

• Single file - Converts an existing electronic document (for example, Word, Excel, or PDF) to an 
interactive PDF form.

• Scanner - Scans a paper form and converts it to an interactive PDF form.

• Create New - Start creating a form from scratch with a blank page. For more information, see How to 
create a form from scratch.

3. If you want others to sign this form, select the This Document Requires Signatures check box.

The form field auto detection is ON, by default. To change this setting, click the Change link and choose the 
settings as appropriate.

4. Click Start.
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Acrobat creates the form and opens it in the Form Editing mode. The right pane displays options for 
editing the form. The toolbar contains form field tools for adding additional fields.

5. Review the form fields Acrobat created. Add fields using the form field tools in the toolbar. Delete, resize, 
or arrange the fields as needed. You can add any of the following types of form fields:

• Add Text field - Add text to the PDF document.

• Barcodes - Encode the input from selected fields and display it as a visual pattern that can be 
interpreted by decoding software or hardware (available separately).

• Buttons - Initiate a change on the user’s computer, such as opening a file, playing a sound, or 
submitting data to a web server. These buttons can be customized with images, text, and visual 
changes triggered by mouse actions.

• Check boxes - Present yes-or-no choices for individual items. If the form contains multiple check 
boxes, the user can typically select as many or few of these as wanted.

• Date field - Lets the user enter a date in the PDF document.

• Digital signature field - Lets the user electronically sign a PDF document with a digital signature.

• Drop-down list - Let the user either choose an item from a pop-up menu or type a value. You can set 
a form field property that enables the user to enter a custom value.

• Image field - Adds an image field. Allows user to browse and select the image to add to the PDF 
document.

• List boxes - Display a list of options the user can select. You can set a form field property that 
enables the user to Shift-click to select multiple items on the list.

• Radio buttons - Present a group of choices from which the user can select only one item. All radio 
buttons with the same name work together as a group.

• Text fields - Let the user type text, such as name, address, or phone number.

6. To change existing text or images, click Edit in the toolbar. All the text and image fields are enabled for 
editing.  

If you don’t see the Edit option in the toolbar, update your Acrobat. To automatically update from Acrobat, 
choose Help > Check for updates, and then follow the instructions in the Updater window to complete the 
update process.

7. To test your form, click the Preview button in the toolbar. Previewing a form allows you to view the form 
the same way the form recipients will and gives you a chance to verify the form. If you are previewing a 
form, you can click the Edit button to go back to the edit mode.

8. When your form is complete, save the form, and then click the Close button towards the right end of the 
toolbar to close form editing.

Create form fields

In Acrobat, you create a form field by choosing one of the form tools. For each field type, you can set various 
options through the form field Properties dialogue box.

1. After you convert your document to a PDF form, do one of the following:
• Choose a form field from the toolbar.

• Right-click the page and select a field.

Your cursor becomes a crosshair, and displays a preview of the field.
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2. On the page, click where you want to add the field to create a field with the default size. To create a field 
using a custom size, drag a rectangle to define the size of the field.

3. In the Field Name box, type the name of the field and specify if you want the field to be a required field. 
Choose a name that is relevant and descriptive to make organizing and collecting the data easier.

4. To display the Properties dialogue box and modify any other field properties, click All Properties.

If you have selected the Keep Tool Selected option  in the toolbar, the Field Name box doesn’t appear after 
adding a field. Each time you click the page, a new field is added to the form. To exit this mode, press the Esc key 
or click the Select Object Tool button . To modify the properties of the field, double-click the field.

5. To test your form, click the Preview button in the toolbar. Previewing a form allows you to view the form 
the same way the form recipients will and gives you a chance to verify the form. If you are previewing a 
form, you can click the Edit button to go back to the edit mode.

6. When your form is complete, click the cross button towards the right end of the toolbar to close form 
editing.

Lay out form fields on a grid

You can use grids to help position form fields precisely on a page. You can define the grid spacing, colour, and 
position. You can also choose whether to have the boundaries of a form field snap to grid lines when you’re 
editing the form field. Grid lines don’t print.

1. Choose View > Show/Hide > Rulers & Grids > Grid.
2. To make form fields snap to the nearest grid lines when you create or move them, choose View > Show/

Hide > Rulers & Grids > Snap To Grid.

Copy a form field

You can create copies of a form field on a single page of a PDF form. You can also copy a form field and paste 
it onto other pages. When you create duplicate form fields, replicas of the original field are added to one or 
more other pages. The duplicate fields are always in the same position on each page as the original. Both 
copies and duplicates can be dragged to different locations on a page, but not from one page to another.

Both copies and duplicates are created with the same basic name as the original form field. Copies and 
duplicates pasted using the Duplicate Across Pages command also have a number appended. All form fields 
with the same basic name share the same user data and action properties. Consequently, when a user adds 
or edits a response to a copy or duplicate field, the response appears in all fields with the same basic name.

If you change the properties of any one of multiple versions of a form field with the same basic name, those 
changes affect only that copy of the form field. The exception is when you change an Actions listing if the 
trigger isn’t a mouse action.

To prevent a duplicate or copied form field from reacting in unison with the original field, change the name of 
the new form field.

Create a copy of a form field

1. If you are not in the form editing mode, choose Tools > Prepare Form.
2. Select the form field, and do one of the following:

• To copy the form field to the center of the current view, choose Edit > Copy, and then choose Edit > 
Paste.

• To copy the form field and move it to another location on the page, Ctrl-drag it.

Tip: To constrain the vertical or horizontal movement as you drag, press and hold Shift.

3. If you want the field to be automatically populated with the data the user types into the original field, 
leave the name as is. If the copied field is for unique user information, rename it.
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Create multiple copies of a form field on a page

1. If you are not in the form editing mode, choose Tools > Prepare Form.
2. Right-click the form field and choose Create Multiple Copies.
3. In the Create Multiple Copies Of Fields dialogue box, select Preview, and move the dialogue box as 

needed so that you can see the original field and the copies on the form page.
4. Make the selections you want to apply:

• To change the number of copies being created, enter different values in the Copy Selected Fields 
Down and Copy Selected Fields Across options.

• To change the dimensions of the original field and all the copies, enter different values in the Change 
Width and Change Height options.

• To move the original field and all the copies, click the Up, Down, Left, and Right buttons.

5. If you want the fields to be automatically populated with the data the user types into the original field, 
leave the names as they are. If the copied fields are for unique user information, rename them.

Duplicate a form field across multiple pages

1. If you are not in the form editing mode, choose Tools > Prepare Form.
2. Right-click the form field and choose Duplicate Across Pages. 

The Duplicate Across Pages command isn’t available for forms with only one page.

3. Do one of the following:
• To duplicate the form field on every page in the form, select All, and click OK.

• To duplicate the form field on a limited range of pages, click the From button, and type the start 
and ending pages on which you want the form field to appear. Then click OK
.

Including or not including the page on which the form field originally appears doesn’t affect the duplication 
process. Including that page won’t create a second copy on top of the original one, and not including it won’t 
remove the original form field.

4. If you want the fields to be automatically populated with the data the user types into the original field, 
leave the names as they are. If the duplicate fields are for unique user information, rename them.

Select multiple form fields

Selecting multiple form fields is the first step for several tasks, such as creating copies, aligning form fields, 
and adjusting the spacing between form fields.

1. If you are not in the form editing mode, choose Tools > Prepare Form.
2. Do any of the following:

• To select all form fields of all types, choose Edit > Select All.
• To select a range of form fields, click the first form field in the range, and then Shift-click the last 

form field. All form fields between the two form fields are selected.

• To select individual form fields in different parts of the PDF page, Ctrl-click each form field.

• To select all form fields in an area of the page, use the Select Object tool  to drag a selection marquee 
around the area.

• To deselect an individual form field, Ctrl-click that field.

The field that is highlighted in dark blue and displays the border handles is the anchor. When you select 
multiple form fields by clicking, the last field selected is the anchor. When you use a marquee, the form 
field that was created first is the anchor. If you Ctrl-click to deselect the anchor, the form field located in 
the upper left of the selection becomes the new anchor form field.

Resize and arrange form fields

After you create form fields, you can rearrange, resize, or move them to give the page a cleaner, more 
professional look.
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Resize a form field

1. If you are not in the form editing mode, choose Tools > Prepare Form.
2. Select the form field that you want to resize.
3. Do any of the following:

• To resize the field manually, drag a border handle. Hold Shift and drag a corner handle to maintain 
the current aspect ratio of the form field.

• To resize the field by one pixel, press Ctrl+Arrow key; to resize the fields by ten pixels, press 
Ctrl+Shift+Arrow key.

• To resize to a specific dimension, right-click the field and choose Properties. Then click the Position 
tab, and adjust the Width and Height values.

Resize multiple form fields to match a selected form field

1. If you are not in the form editing mode, choose Tools > Prepare Form.
2. Select all the form fields that you want to resize.
3. Choose an appropriate option in the right hand pane under Match Size.

You can also right-click the form field that you want the other selected form fields to match. Choose Set 
Fields To Same Size, and then select one of the following:
• Height  -Adjusts the heights without changing the widths.

• Width  - Adjusts the widths without changing the heights.

• Both  - Adjust all widths and heights to match.

Move individual form fields

You can move form fields by simply dragging them. For greater precision in less time, you can use special 
features that align them with each other, adjust the spacing between them, and center them on the page.
1. If you are not in the form editing mode, choose Tools > Prepare Form.
2. Select one or more form fields that you want to move.
3. Do one of the following:

• To move to an approximate location, drag the selected form fields to the new location.

Tip: To constrain movement to a horizontal or vertical direction, begin dragging, and then press Shift 
while continuing to drag the selection.

• To move to a specific location, right-click the field and choose Properties. Then click the Position 
tab, and set the Position values.

• To move either horizontally or vertically in small increments, press the arrow keys to nudge the 
selected form field into position.

• To move the form field to the exact center of a page, choose Edit > Cut, navigate to the desired 
page, and then choose Edit > Paste.

Fields are placed in the center of the page only the first time they’re pasted. Additional pasted fields are 
offset from the previously pasted field.

Align and center multiple form fields

1. If you are not in the form editing mode, choose Tools > Prepare Form.
2. Select two or more form fields that you want to align.
3. Click appropriate option in the right hand pane.

You can also right-click the field to which you want to align the other fields. Choose Align, Distribute Or 
Center, and then choose a command as follows:

• To align a column of fields, choose Align Left, Right, or Vertical. They align respectively to the left 
edge, right edge, or vertical axis (center) of the anchor form field.

• To align a row of fields, choose Align Top, Bottom, or Horizontally. They align respectively to the top 
edge, bottom edge, or horizontal axis (center) of the anchor form field.
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• To center the fields, choose Center Vertically, Horizontally, or Both.

When you right-click one of the selected fields, it shows the border handles, indicating that it’s the anchor 
form field. The Align menu commands move the other selected form fields to line up with the edges of the 
anchor form field.

Adjust the spacing between form fields

In the context of laying out form fields on a page, distributing means to give a group of form fields uniform 
spacing, measured from the centres of adjacent fields. The Distribute commands take precedence over the 
Snap To Grid command.
1. If you are not in the form editing mode, choose Tools > Prepare Form.
2. Select the form fields that you want to adjust.
3. Choose an appropriate option in the right hand pane under Distribute.

You can also  right-click any one of the selected form fields, and do one of the following:
• To distribute the fields evenly between the topmost and bottommost fields, choose Align, Distribute 

Or Center >Distribute Vertically.

• To distribute the fields evenly between the leftmost and rightmost fields, choose Align, Distribute 
Or Center >Distribute Horizontally.

Note: The Distribute command at the bottom in the right hand pane has a different function. Use that 
command to send your form to others, who fill in the information and return the data to you.

Delete a form field

1. If you are not in the form editing mode, choose Tools > Prepare Form.
2. In the right hand pane under Fields or the page view, select the form fields that you want to delete.
3. Right-click and choose Delete, or choose Edit > Delete.

About form field properties

How a form field behaves is determined by settings in the Properties dialogue box for that individual field. 
You can set properties that apply formatting, determine how the form field information relates to other 
form fields, impose limitations on what the user can enter in the form field, trigger custom scripts, and so on.

You can set various properties for an Acrobat form field, depending on the form field type. The properties 
for each type of form field are selected on a series of tabs. When you change a property, it is applied as soon 
as you select another property or press Enter.

All types of form fields have a General tab and an Actions tab. Other tabs appear only in specific types of 
form fields. The Options tab appears for most form field types but the options available are unique to each 
type of form field.

Two items are available on every tab. If you select one on any tab, a check mark will appear, and the option 
will be checked on all tabs. These are:
• Locked - When selected, prevents any further changes to any form field properties.

• Close - Closes the form field Properties dialogue box. If you are changing the properties of multiple fields, 
you can leave the Properties dialogue box open. Click each field to change its properties.

If you select Locked on any tab, it locks all options for the field, not just the options on that tab.
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Modify form field properties

You can access form field properties only when you are in editing mode. You can change the properties for 
multiple form fields at a time.
1. If you are not in form editing mode, choose Tools > Prepare Form.
2. Open the Properties dialogue box using one of the following methods:

• To edit a single form field, double-click it or right-click it and choose Properties.

• To edit multiple form fields, select the fields that you want to edit, right-click one of the selected 
fields, and choose Properties.

3. Change the properties on each of the available tabs, as needed.
The property is changed as soon as you select another property or press Enter.

4. Click Close.

If you select form fields that have different property values, some options in the Properties dialogue box are 
not available. Otherwise, changes to the available options are applied to all selected form fields.

To avoid accidental changes to the form field, select Locked in the lower-left corner of the Properties dialogue 
box before you close it. To unlock, click the option again.

General tab for form field properties

The General tab appears for all types of form fields and includes the following options:

Name - Specifies the unique name of the selected form field.

Tooltip -  Displays text that the hesitant user may find helpful in filling in the form field. Tooltips appear 
when the pointer hovers briefly over the form field.

Form Field - Specifies whether the form field can be seen, either on screen or in print. The choices are: 
Visible, Hidden, Visible But Doesn’t Print, and Hidden But Printable.

Orientation- Rotates the form field by 0, 90, 180, or 270 Degrees

Read Only - Prevents the user from changing the form field content.

Required - Forces the user to fill in the selected form field. If the user attempts to submit the form while a 
required field is blank, an error message appears and the empty required form field is highlighted.

Appearance tab for form field properties

Appearance properties determine how the form field looks on the page. The Appearance tab appears for all 
types of form fields except barcodes, and includes the following options:

Border Colour - Opens a colour picker in which you can select a colour swatch for the frame surrounding the 
field. To leave the field without a frame, select No Colour.

Line Thickness - Specifies the width of the frame surrounding the form field: Thin, Medium, or Thick.

Fill Colour - Opens a colour picker in which you can select a colour swatch for the background behind the 
field. To leave the field uncoloured, select No Colour.note: A Fill Colour choice other than No Colour will block 
any images on the PDF page that are behind the form field.

Line Style - Alters the appearance of the frame. Select Solid, Dashed, Bevelled, Inset, or Underline.

Font Size- Sets the size of user-entered text or of the selection marker for radio buttons and check boxes. 
The choices include Auto, various preset values, and typing in a different value. If you select Auto for a text 
field, as the user types, the font size changes to fit the text in the box.

Text Colour - Opens a colour picker in which you can select a colour swatch for the text or selection marker.

Font - Lists the fonts available on your computer. This option is not available for form fields that do not 
display text.
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The Enable Right-To-Left Language Options in the Language panel of the Preferences dialogue box affects what 
appears in the Appearance tab of the Properties dialogue box. When that preference is selected, the Appearance 
tab includes options for changing the digit style and text direction for text fields, drop-down list boxes, and list 
boxes.

Position tab for form field properties

The Position tab lets you position or size the currently selected field or fields. You can move fields to the 
location you specify on the page. Use the Height and Width options to change only the size of fields. To move 
fields without resizing them, choose Do Not Change Height And Width When Changing The Position.

Options tab for form field properties

The options available on this tab change according to the type of form field selected. The Options tab 
appears for all form field types except digital signatures.

Check boxes

Check Box Style - Specifies the shape of the marker that appears inside the check box when the user selects 
it: Check (the default), Circle, Cross, Diamond, Square, or Star. This property does not alter the shape of the 
check box itself. Note: The size of the marker inside the check box is determined by the size of the font you 
specify in the Appearance tab.

Export Value- Specifies a value to represent the item if the data will be exported. If left blank, the entry for 
Name in the General tab is used as the export value.

Check Box Is Checked By Default - Shows the check box selected unless the user deselects it.

Drop-down and list box

For either dropdown boxes or list boxes, you use the Options tab to create a list of items from which the user 
selects.

Although most of the properties on this tab are common to both these types of form fields, a few are 
exclusive to one type or the other.

Item - Accepts the text that you type for options that you want to appear in the menu for the field.

Add - Moves the current entry in Item to the Item List.

Export Value - Where you type in a value to represent the item if the data will be exported. If left blank, the 
entry for Name in the General tab is used as the export value.

Item List - Displays the choices that will be available in the list.note: The highlighted item in the Item List 
box appears as the default selected item in the dropdown box or list box field. To change the default item, 
highlight another item from the list.

Up and Down buttons - Change the order in which the items are listed in the drop-down list. These buttons 
are not available if Sort Items is selected.

Delete - Removes the selected item from the list.

Sort Items - Arranges the listed items numerically and alphabetically. A numerical sort (if applicable) is 
performed before an alphabetical sort.

Allow User To Enter Custom Text - (Dropdown only) Enables users to enter a value other than the ones in 
the list.
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Check Spelling - (Dropdown only) Checks the spelling of user-entered text. This option is applicable only if 
Allow User To Enter Custom Text is selected.

Multiple Selection - (List boxes only) Enables users to choose more than one item in the list.

Commit Selected Value Immediately - Saves the value as soon as the user selects it. If this option is not 
selected, the value is saved only when the user tabs out of the current field or clicks another form field. For 
list boxes only, this option is not available if Multiple Selection is selected.

Radio buttons

Create a group of radio buttons if you want the user to select only one choice among a set of choices. All the 
radio buttons in a group have the same Name, but each button has a different Button Value.

Button Style - Specifies the shape of the marker that appears inside the button when the user selects it: 
Check, Circle (the default), Cross, Diamond, Square, or Star. This property does not alter the shape of the 
radio button itself.

Radio Button Choice - Identifies the radio button and differentiates it from other radio buttons that have 
the same Name value.

Button Is Checked By Default - Sets the selection state of the button when the user first opens the form.

Buttons With The Same Name And Content Are Selected In Unison - Allows single-click selection of 
multiple related radio buttons. For example, if the user selects a radio button that has the same field name 
and selected content as another, both radio buttons are selected.

Text Fields

Text fields accept user input, which can be alphabetic characters, numbers, or both.

Alignment - Aligns the text left, right, or center within the field.

Default Value - Specifies the text that appears until the user overwrites it by typing in the field. Enter the 
default value by typing in this option.

Multi-line - Allows more than a single-line entry in the text field.

Scroll Long Text - Compensates for text that extends beyond the boundaries of the text field.

Allow Rich Text Formatting - Allows users to apply styling information to the text, such as bold or italic. This 
might be useful in certain text fields where such styling information is important to the meaning of the text, 
such as an essay.

Limit Of Characters - Allows entries of up to the number of characters you specify.

If you entered a default value, that value is clipped to this limit.

Password - Displays the user-entered text as a series of asterisks (*). This option is available only if Check 
Spelling is deselected.

Field Is Used For File Selection - Allows the user to enter a file path as the field’s value when a file is 
submitted along with the form. This option is available only when Scroll Long Text is the only selected option 
in the Options tab.

Check Spelling - Checks the spelling of user-entered text.

Comb Of Characters - Spreads the user-entered text evenly across the width of the text field. If a border 
colour is specified in the Appearance tab, each character entered in the field is separated by lines of that 
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colour. This option is available only when no other check box is selected.

Text fields with and without the Comb property
A. Four text fields with a border colour, using the Comb property B. Text field without the Comb property 

Actions tab for form field properties

Actions properties specify any actions that you want to associate with the form field, such as jumping to a 
specific page or playing a media clip. The Actions tab appears for all types of form fields and includes the 
following options:

Select Trigger - Specifies the user action that initiates an action: Mouse Up, Mouse Down, Mouse Enter, 
Mouse Exit, On Focus, or On Blur.

Select Action - Specifies the event that occurs when the user triggers the action: Execute A Menu Item, 
Go To A 3D/Multimedia View, Go To A Page View; Import Form Data, Multimedia Operation (Acrobat 9 and 
later), Open A File, Open A Web Link, Play A Sound, Play Media (Acrobat 5 Compatible), Play Media (Acrobat 
6 And Later Compatible), Read An Article, Reset A Form, Run A JavaScript, Set Layer Visibility, Show/Hide A 
Field, and Submit A Form.

Add - Opens a window for the selected action.

Actions - Displays the list of triggers and actions that you’ve defined.

Up and down buttons - Change the order in which the selected action appears listed under the trigger. 
(Available only when you have defined multiple actions for the same trigger.)

Edit -  Opens a dialogue box with specific options for the selected action.

Delete - Removes the selected action or trigger-action pair.

Calculate tab for form field properties

The Calculate tab appears in the Properties dialogue boxes for only text fields and dropdown boxes. Use 
these options to perform mathematical operations on existing form field entries and display the result.

Value Is Not Calculated - Select this if you want the user to type.

Value Is The - Select this to make further options available:

Pop-up menu - Lists the mathematical functions to apply to the selected fields. Choose Sum to add the 
values entered in the selected fields, Product to multiply them, Average, Minimum, or Maximum.

Pick- Opens a dialogue box with a list of the available fields in the form that you select to add or deselect to 
remove from the calculation.

Simplified Field Notation - Uses JavaScript with field names and simple arithmetic signs. The Edit button 
opens a dialogue box in which you can write, edit, and add scripts.

Field names are case-sensitive.

Custom Calculation Script - Displays any custom scripts you have added for calculations. The Edit button 
opens a dialogue box in which you can write and add new JavaScripts.
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Set the calculation order of form fields

When you define two or more calculations in a form, the order in which they are carried out is the order in 
which you defined the calculations. In some cases, you may need to modify the calculation order to obtain 
correct results.

For example, if you wanted to use the result obtained from calculating two form fields to calculate the value 
of a third form field, the first two form fields must be calculated together first to obtain the correct final 
results.
1. In the right hand pane, choose More > Set Field Calculation Order. 

The Calculate Fields dialogue box displays all calculable fields in your form and the order in which the 
calculations are performed.

2. To change the field calculation order, select the field from the list, and then click the Up or Down 
button as needed.

Acrobat automatically performs all assigned field calculations when you are creating and testing your form 
fields. For convenience, while you work, you can turn off automatic calculation in the forms preferences.

Signed tab for form field properties

The Signed tab is available only in the Digital Signature Properties dialogue box. Selections made here 
determine what happens when the user applies a digital signature to the form.

Nothing Happens When Signed - This is the default.

Mark As Read-Only - Prevents further changes to the digitally signed form, according to the selection in the 
pop-up menu:

All Fields - Prevents any changes to any form field.

All Fields Except These - Allows changes only to the form fields you select by clicking the Pick button and 
selecting check boxes for the fields that you want the user to be able to edit after signing.

Just These Fields - Prevents changes in only the form fields you pick.

This Script Executes When Field Is Signed - Activates a custom JavaScript when the user digitally signs the 
form. Use the Edit button to change or create a new JavaScript action.

Format tab for form field properties

The Format tab appears in the Properties dialogue box for only text form fields or dropdown form fields. 
The options that are available depend on your selection in the Select Format Category pop-up menu.

The Example of Current Format field displays a live preview of the settings.

None 

No additional options are available. The input in a text or dropdown box with this property does not require 
any specific formatting.

Number 

Automatically imposes the selected formatting options on numeric data entries.
Decimal Places - Sets the number of digits that appear to the right of the decimal point.

Separator Style - Sets the placement of commas and periods.

Currency Symbol - Sets the type of currency, such as Euros, Dollars, or Yen.
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Symbol Location - Sets the location of the currency symbol in relation to the number. This field is enabled if 
a currency symbol is selected.

Negative Number Style - Sets how negative numbers are displayed. You can choose Show Parentheses, Use 
Red Text, neither, or both.

Percentage

Automatically imposes the selected formatting options on numeric data expressed as a percentage.
Decimal Places - Sets the number of digits that appear to the right of the decimal point

Separator Style - Sets the placement of commas and periods.

Date 

List includes one-, two-, and four-digit variations where
d - stands for the day, 
m - stands for month, and 
y - stands for year.

Time 

List includes display variations where h stands for the hour on a 12-hour clock, 
H -  stands for the hour on a 24-hour clock, 
MM - stands for minutes, 
ss - stands for the seconds, and 
tt - stands for AM or PM.

Special

Zip Code - For a five-digit U.S. postal code.
Zip Code + 4 - For a nine-digit U.S. postal code.
Phone Number - For a ten-digit telephone number.

Social Security Number - For a nine-digit U.S. Social Security Number. Hyphens are inserted automatically 
after the third and fifth digits.

Arbitrary Mask - Changes the format category to Custom and makes another text field available, in which 
you can type a custom format. Use this option to specify which types of characters the user can enter in any 
given position, and how the data displays in the field.

A - Accepts only letters (A–Z, a-z).

X - Accepts spaces and most printable characters, including all characters available on a standard keyboard 
and ANSI characters in the ranges of 32–126 and 128–255.

O - The letter “O” accepts alphanumeric characters (A–Z, a-z, and 0–9).

9 - Accepts only numeric characters (0–9).For example, a mask setting of AAA--p#999 accepts the input 
BOE--p#767. A mask setting of OOOOO@XXX accepts the input vad12@3Up.
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Example of an Arbitrary Mask entry

Custom

Makes additional options available to form designers who want to write their own JavaScripts for formatting 
and keystrokes. For example, a custom script could define a new currency format or limit the user entry to 
specific keystroke characters.

Custom Format Script - Displays any custom scripts you have added for formats. The Edit button opens a 
dialogue box in which you can write and add new scripts.

Custom Keystroke Script - Displays any custom scripts you have added to validate keystrokes. The Edit 
button opens a dialogue box in which you can write and add new scripts.

Validation tab for form field properties

The Validation tab appears only in the Text Field Properties and Dropdown box Properties dialogue boxes. 
Validation properties restrict entries to specified ranges, values, or characters, ensuring that users enter the 
appropriate data for a specified form field.

Field Value Is Not Validated - Turns off validation.

Field Value Is In Range - Sets a numeric range for form fields using values you enter in either as a number 
or a percentage.

Run Custom Validation Script - Validates by a JavaScript that you create or provide.

Value tab for form field properties

The Value tab appears for barcode form fields only.

Encode Using - Activates these options:

XML - Encodes the data into the barcode in standard XFDF format. JavaScript script is automatically 
generated.
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Tab Delimited -  Encodes the fields into the barcode as tab-delimited values. JavaScript script is automatically 
generated. If the form is configured to output the data in individual XFDF or XDP files, the data must be in 
a tab-delimited format with the field names in the first line. This option is also useful if you want to fit more 
data into a barcode or if you intend to copy the data into database or spreadsheet tables.

Pick -  Opens a dialogue box in which you select which user data fields will be encoded in the barcode for 
you to retrieve.

Include Field Names - (Available only when Tab Delimited encoding is selected.) Encodes field names as the 
first line of the barcode contents. The values are encoded under them.

Custom Calculation Script - Displays the default script. Click the Edit button to open the JavaScript Editor 
dialogue box, in which you can write custom calculation scripts for your barcode.

Reference To published Form - Shows the path to the PDF form. You can edit this by typing in the URL to 
the published form. Later, you can re-create a digital version of the completed form by merging the form 
template with an instance of user-supplied data. You can also maintain the relationship between a specific 
form template and its related barcode data files. When you encode a barcode using XML values, the URL 
reference is encoded into the barcode and is displayed on the form,

Redefine form field property defaults

After you change properties for a specific type of form field, you can set those properties as the default set 
for that type. For example, you can create a checkbox, change its properties, and then save the properties 
as the default values. The default values can be only for Appearance and Size related attributes of the field. 
Properties for format related attributes like Date cannot be set as default.
1. If necessary, choose Tools > Prepare Form to go to form-editing mode.
2. Right-click the form field for which you have already changed properties, and choose Use Current 

Properties As New Defaults.

Changing the default properties does not change the settings for existing form fields of that type. The new 
defaults apply only to new fields that you create.

Setting action buttons in PDF forms

About buttons

Buttons are most commonly associated with forms, but you can add them to any document. Buttons can 
open a file, play a sound or movie clip, submit data to a web server, and much more. When deciding on how to 
initiate an action, remember that buttons offer the following capabilities that links and bookmarks do not:
• A button can activate a single action or a series of actions.

• A button can change appearance in response to mouse actions.

• A button can be easily copied across many pages.

• Mouse actions can activate different button actions. For example, Mouse Down (a click), Mouse Up 
(releasing after a click), Mouse Enter (moving the pointer over the button), and Mouse Exit (moving the 
pointer away from the button) can all start a different action for the same button.

Buttons are an easy, intuitive way to let users initiate an action in PDF documents. Buttons can have 
a combination of labels and icons to lead users through a series of actions or events by changing as the 
mouse is moved. For example, you can create buttons with “Play,” “Pause,” and “Stop” labels and appropriate 
icons. Then you can set actions for these buttons to play, pause, and stop a movie clip. You can select any 
combination of mouse behaviors for a button and specify any combination of actions for a mouse behavior.
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Add a button to an Acrobat PDF form

1. Make sure you are in edit mode by selecting Tools > Prepare Form, and then select Button  in the toolbar. 
Your curser becomes a cross hair.

2. On the page, click where you want to add the button to create a button with the default size. For a 
custom size button, drag a rectangle to define the size of the button.

3. Double-click the button field, and then specify a name, tool tip text, and other common properties.
4. Click the Appearance tab, and then specify options to determine the button appearance on the page. 

Remember, if you select a background color, you are not able to see through to any images behind the button. 
The text options affect the label you specify in the Options tab, not the button name in the General tab. 

If Enable Right-To-Left Language Options is selected in the International panel of the Preferences dialog box, 
the Appearance tab includes options for changing the digit style and text direction for buttons.

5. Click the Options tab, and select options to determine how labels and icons appear on the button.
6. Click the Actions tab. Specify options to determine what happens when the button is clicked, such as 

jumping to a different page or playing a media clip.
7. Click Close.

If you’re creating a set of buttons, you can snap the object to grid lines or guides.

8. To preview and test the button, click Preview at the right-end of the toolbar. Once you are done, you can 
either click Edit to return to the Prepare Form tool, or click the cross icon at the right-end of the toolbar 
to close the tool.

Add a submit button

When you distribute a form, Acrobat automatically checks the form. If it doesn’t find a submit button, it 
adds a Submit Form button to the document message bar. Users can click the Submit Form button to send 
completed forms back to you. If you don’t plan to use the Submit Form button created by Acrobat, you can 
add a custom submit button to your form.
1. If you are not in form editing mode, choose Tools > Prepare Form.
2. Using the Button tool, drag across the area where you want the button to appear. Double-click the 

button and set options in the General and Options tabs.
3. In the Options tab, choose an option in the Layout menu for the button label, icon image, or both. Do 

one or both of the following:
• Type text in the Label box to identify the button as a submit button.

• Click Choose Icon and either type the path to an image file or click Browse and locate the image file 
you want to use.

4. In the Actions tab, choose Submit A Form in the Select Action menu, and then click Add.
5. In the Submit Form Selections dialog box, do one of the following:

• To collect form data on a server, type the location in the Enter a URL for this link box. For example, 
http://www.[domain]/[folder]/[subfolder]/ for an Internet address or \\[server]\[folder]\
[subfolder]\ for a location on a local network.

• To collect form data as attachments to email, type mailto: followed by the email address. For 
example, mailto:nobody@xyz.com.

6. Select options for Export Format, Field Selection, and Date Options, and click OK.
7. Click Close.
8. To preview and test the button, click Preview at the right-end of the toolbar. Once you are done, you can 

either click Edit to return to the Prepare Form tool, or click the cross icon at the right-end of the toolbar 
to close the tool.

If the data returns in FDF or XFDF format, the server URL must end with the #FDF suffix—for example, http://
myserver/cgi-bin/myscript#FDF.
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Submit Form Selections options

The following options are available in the Submit Forms Selections dialog box:

Enter a URL for this link - Specifies the URL to collect the form data.
FDF - Returns the user input without sending back the underlying PDF file. You can select options to include 
Field Data, Comments, and Incremental Changes To The PDF.

Selecting the option for incremental changes is useful for receiving digital signatures in a way that is easily read 
and reconstructed by a server.

HTML - Returns the form in Hypertext Markup Language.
XFDF - Returns the user input as an XML file. You can include Comments with the field data or just the field 
data.
PDF - Returns the entire PDF file with the user input.
Field Selection - Specifies what fields are returned. To receive only some of the completed field data, select 
Only These, click Select Fields, and select which fields to include or exclude in the Field Selection dialog box. 
For example, you might use this to exclude some calculated or duplicate fields that appear in the form for 
the user’s benefit but which do not add new information.
Date Options - Standardizes the format for dates that the user enters.

Making buttons change appearance

A button can have a label, an icon, or both. You can change how the button appears in each mouse state 
(Up, Down, and Rollover). For example, you could create a button that has a “Home” label until the pointer is 
moved over the button, when it might have a “Click to return to home page” label.

You can make button icons from any file format that Acrobat can display, including PDF, JPEG, GIF, and other 
image formats. For whichever format you select, the entire page is used, so if you want to use only a portion 
of a page as an icon, you need to crop the image or page before carrying out this procedure. The smallest 
allowable PDF page size is 1-by-1 inch (2.54-by-2.54 cm). If you want the icon to appear smaller than 1-by-1 
inch, scale it to fit the size of the box drawn with the button tool. Clicking Advanced in the Options tab of the 
Button Properties dialog box lets you determine how a button icon is scaled to fit inside a button.

Button layouts
A. Label only B. Icon only C. Icon top, label bottom D. Label top, icon bottom E. Icon left, label right F. Label left, icon 
right G. Label over icon 

Edit a button

1. If you are not in form editing mode, choose Tools > Prepare Form.
2. Select the Button field, and then do any of the following:

• To edit the properties for the button field, double-click the button.

• To change the appearance of buttons, use the appearance options in the Appearance tab of the 
Button Properties dialog box.

• To align, center, or distribute the button with other form fields, or to resize or duplicate the button, 
right-click the button, and then choose an option from the context menu.

3. Close all opened dialog boxes, if any. Click the cross icon at the right-end of the Prepare Form toolbar to 
close the tool.

Specify Acrobat button display properties

1. If you are not in form editing mode, choose Tools > Prepare Form.
2. Double-click an existing button, and then click the Options tab in the Button Properties dialog box.
3. For Layout, choose the type of label display you want. (For information on scaling button icons, see the 

next procedure.)
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4. For Behavior, specify the display of the button when clicked.
5. To define the label or icon that appears on the button, do the following:

• If a label option is selected from the Layout menu, type the text in the Label box.

• If an icon option is selected from the Layout menu, click Choose Icon, click Browse, and select the 
file. (Click Clear to remove the selected icon.)

6. Close all opened dialog boxes, if any. Click the cross icon at the right-end of the Prepare Form toolbar to 
close the tool.

Button Behavior options

None - Keeps the appearance of the button the same.

Push - Specifies appearances for the Up, Down, and Rollover states of the mouse. Select an option under 
State, and then specify a label or icon option:

Up - Determines what the button looks like when the mouse button isn’t clicked.

Down - Determines what the button looks like when the mouse is clicked on the button, but before it’s 
released.

Rollover - Determines what the button looks like when the pointer is held over the button.

Outline - Highlights the button border.

Invert - Reverses the dark and light shades of the button.

Scale and position buttons

1. If you are not in form editing mode, choose Tools > Prepare Form.
2. Double-click an existing button to open the Button Properties dialog box.
3. Click the Options tab, select one of the icon options from the Layout menu, and then click Advanced.

The Advanced button isn’t available if you choose Label Only from the Layout menu.

4. Select an option from the When To Scale menu:
Always - Scales the icon as defined regardless of its size in relation to the button size.

Never - Preserves the original size of the icon; the button border crops the icon if it doesn’t fit. If Never 
is selected, scale options aren’t available.

Icon Is Too Big - Scales the icon as defined only if it is larger than the button.

Icon Is Too Small - Scales the icon as defined only if it is smaller than the button.

5. From the Scale menu, select whether to scale the icon proportionally. If the icon is scaled nonproportionally, 
it may be skewed.

6. To make sure that either the top and bottom or left and right sides of the icon are flush against the 
button edges, select Fit To Bounds.

7. To define where the icon is placed inside the button, drag the slider arrows. Icon placement is defined 
according to the percentage of space preserved between the icon and the left field boundary, and 
between the icon and the bottom field boundary. The default setting (50, 50) places the icon in the 
middle of a field. You can click Reset at any time to revert to the default placement setting.

8. Click OK, and then click Close.
9. To preview and test the button, click Preview at the right-end of the toolbar. Once you are done, you can 

either click Edit to return to the Prepare Form tool, or click the cross icon at the right-end of the toolbar 
to close the tool.
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Hide an Acrobat button except during rollover

In some cases, you may want the button area to be invisible until the pointer moves over it. By alternately 
showing and hiding a button, you can create interesting visual effects in a document. For example, when you 
move a pointer over a city on a map, a detail map of the city could be displayed, and the detail map could 
disappear when the pointer moves away from the city.

Showing and hiding icons
A. Pointer not over button area B. Pointer enters button area C. Pointer exits button area 

1. If you are not in form editing mode, choose Tools > Prepare Form.
2. Using the Button tool , drag across the area where you want the pop-up button to appear. For example, 

if the PDF file contains a map of France, drag across the area where you want a detailed map of Paris to 
pop up.

3. Double-click the button, and then click the Options tab and choose Icon Only from the Layout menu.
4. Choose Push from the Behavior menu, and then choose Rollover from the State list.
5. Click Choose Icon, and then click Browse. Select the file type from the File Of Type, navigate to the 

location of the image file, and then double-click the file. In this example, you would select a map of Paris. 
Click OK to accept the previewed image as the button.

6. Click the Appearance tab. If needed, deselect Border Color and Fill Color, and then click Close.
7. If you are in the edit mode, click Preview. The image field you defined appears as the pointer rolls over 

the button area and disappears when it exits.

If you want the image to be larger than the rollover area, or if you want the image to be in a different location 
than the image button that pops up, use the Show/Hide A Field action. First, you specify an icon for the button 
that will be shown and hidden. Next, you create a second button that acts as a hot spot when the mouse rolls 
over it. You do not assign an icon for the appearance of the second button. Instead, you use the Actions tab to 
show the first button when the pointer enters the second button, and hide the first button when the pointer exits.

8. Once you are done, you can either click Edit to return to the Prepare Form tool, or click the cross icon at 
the right-end of the toolbar to close the tool.

Enable Reader users to save form data

Ordinarily, users of Acrobat Reader DC and earlier can’t save filled-in copies of forms that they complete. 
However, you can extend the rights of a PDF to allow these users to save form data. If you have Acrobat 
DC Pro, you can include additional capabilities for Acrobat Reader DC users, such as adding text to non-
interactive forms.

Unlike earlier versions of Reader, Reader XI and higher versions of Reader include both the Add Text tool and the 
ability to save form data. Acrobat users can type in non-fillable forms, add comments, and digitally sign PDFs 
without extending special rights.

1. Open a single PDF, or preview a component PDF in a PDF Portfolio.
2. If you are editing the form, click the cross icon next to the Preview button in the upper-right corner.
3. Choose File > Save As Other > Reader Extended PDF, and choose one of the following options:

• Enable Commenting & Measuring - (Acrobat Pro) Allows users to add comments or access the 
Object Data, Measuring, and Geospatial tools.

• Enable More Tools (includes form fill-in & save) - Lets users save data they’ve entered in interactive 
or fillable forms.

Notes on saving filled-in forms locally

Both Acrobat Standard and Acrobat Pro allow Adobe Reader 8 or later users to fill in and save PDF forms 
locally.
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Adding JavaScript to forms

The JavaScript language lets you create interactive web pages. Adobe has enhanced JavaScript so that you 
can easily integrate interactivity into PDF forms. The most common uses for JavaScript in Acrobat forms are 
formatting, calculating, validating data, and assigning an action. In Windows, you can also configure Adobe 
PDF forms to connect directly to databases using Open Database Connection (ODBC).

If you’re creating dynamic forms, keep in mind that Acrobat Reader doesn’t support some custom JavaScripts. 
The form may not function properly when viewed in Acrobat Reader unless additional usage rights are added to 
the PDF.

Additional resources
For more information on Acrobat JavaScript, see these resources:
JavaScript™ for Acrobat® API Reference to add interactivity to PDF forms:  
www.adobe.com/go/learn_acr_ javascript_en (PDF, English only)

Acrobat Software Development Kit (SDK) to customize Acrobat: 
www.adobe.com/go/learn_acr_devcenter_en (English only)

File paths in Acrobat JavaScript: www.acrobatusers.com/tutorials/file-paths-acrobat-javascript

Distribute (send) forms to recipients

Distribute PDF or web forms

After you create a form, you choose a method for sending it to recipients.
1. Click Distribute in the lower-right corner of the right pane.
2. A series of messages might appear, depending on the conditions Acrobat detects in your form. Respond 

to the onscreen instructions as needed, and save the form.
3. Choose a distribution and collection method:

• Email - Collect responses in your email inbox.

• Internal Server - Distribute and collect responses on an internal server such as SharePoint or 
Network Folder. For more information, see Specify a server.

4. Click Continue and follow the onscreen instructions for distributing the form.
5. If you choose to collect responses in your email inbox, do one of the following:

• Enter the email addresses separated with a semi-colon, or click the To button to select email 
addresses from your address book.

• Edit the default message.

• Select the option Collect Name & Email from Recipients To Provide Optimal Tracking. The system 
prompts recipients to provide their name and email address when they submit the form. This 
guarantees that in Tracker, you see exactly who has and hasn’t replied, and when.

• Deselect the option if you want to receive anonymous submissions, or you don’t care about that 
level of tracking.

If you don’t know the email addresses of your recipients, enter your own email address. The system sends you a 
link to the form, which you can email to recipients as desired.

To track the status of the distributed form, click Track in the lower-right corner of the right pane. For more 
information, see About forms tracker.

Distribute Adobe Sign forms

After you create an Adobe Sign form, you can use Adobe Sign service for sending it to recipients for filling 
in and signing.

1. Click Send For Signatures in the lower-right corner of the right pane.
2. Click Ready to Send. The document is uploaded to Adobe Document Cloud.
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3. Type in the email addresses of people you want to sign your document. Add a message if desired.
4. Click Send.

You receive an email from Adobe Sign which states that the documents are sent to the first user for signature. 
The first user also receives an email to sign the document. When the user adds his or her signature in the 
Signature field, and then click the Click to sign button, the document is sent to the next user for signature 
and so on.

Everyone gets a copy of the signed document, and the file is stored securely in Adobe Document Cloud.

Track forms

Use Tracker to manage the forms that you have distributed or received. Tracker allows you to view and 
edit the location of the response file, track which recipients have responded, add more recipients, email all 
recipients, and view the responses for a form.

1. In Acrobat, choose Edit > Form Options > Track or View > Tracker.
2. In the left navigation panel, expand Forms.
3. Select a form and do one of the following:

• To view all responses for a form, click View Responses.

• To modify the location of the response file, in Responses File Location, click Edit File Location.

• To view the original form, click Open Original Form.

• To send the form to more recipients, click Add Recipients.


